ThinkPad X260のACアダプター認識不良を修理した記録

ページのアイキャッチ画像ThinkPad X260

以前、起動不能状態のジャンクなX260を復活させて、メモリ32GB化、Wi-Fi6化などを行ったことについて記録しましたが、実はその後、ACアダプターの認識不良?があることに気付きました。

ジャンク出身?のX260ですが、CPUがCore i7だったこともあり、なんとか正常に戻したいという強い思いから、気合いを入れて原因究明~修理までを行いましたので記録しておきます。

↓ 以前の記録 ↓

通電するが起動しない!ジャンク X260を修理した記録

ThinkPad X260 メモリ増設 32GBに交換!

X260 / X270でWi-Fi6 内蔵カード取付けを試す!

スポンサーリンク

間違ったACアダプターが挿さりました!

不具合の状況はこうです。

ACアダプターを接続していない状態、すなわちバッテリー駆動でWindowsを立ち上げると、起動直後に「間違ったACアダプターが挿さりました。」とメッセージが・・・?
いやいや、ACアダプターは挿してないんだけど・・・

Incorrect MSG

仕方ないので、『OK』ボタンを押して、そのまま操作を続けるていると数分おきにこの意味不明のメッセージが表示されます。
なんじゃこれは???

また、ACアダプター接続状態でWindowsを立ち上げた後、ACアダプターを抜いても同じように表示されます・・・??

そして、ACアダプターを抜いている時は、電源ボタンの緑LEDと天板のThinkPadロゴ部にある赤LEDが点滅します
よって、X260をシャットダウンした後、ACアダプターを抜くと(またはコンセントからプラグを抜くと)保管中でも、ずーっと天板のThinkPadロゴが点滅状態となり、とっても目障りです
おそらく、バッテリーが切れるまで点滅を続けるのでしょう。

電源LED点滅状態r

試しに、BIOSの「Config」→「Power」→「Built in Battery」でバッテリーからの給電を切ると、ようやく点滅が止まりました。

ただ、これ以外に不具合はなく、ACアダプターを挿して給電していると、まったく普通に使えるので、修理せずに放置しようかとも考えましたが、ThinkPadロゴの点滅がとても鬱陶しく、シャットダウンするたびに、毎回BIOSでバッテリーを切るのはとっても面倒です。

という訳で、なんとか修理できないか?と調査を開始しました!

BIOS書き換え → NG

ジャンクX260を復旧させる際、BIOSデータはネット上から適当なものを拾って流用しましたが、もしかしたら、そのデータ自体に不具合があるかもしれない・・・と考え、まずは別のBIOSデータを拾って書き換えしてみました。
が・・・、結果変化なし

また、X260のシステムボード(NM-A531)には、Rev:3.0と4.0の2種類が存在しており、ジャンクX260はRev:4.0だったので、Rev:4.0と明確に記載されているBIOSデータを流用していましたが、試しに3.0のBIOSデータを書き込んでみたらどうなるか?
が・・・、これも変化ありませんでした

Rev:3.0 & 4.0

ということで、BIOSデータは「問題なし」との結論にいたりました。

そもそも、Rev:3.0と4.0でBIOSデータの内容が異なるのか?は不明です。
ちなみに、Rev:1.0や2.0も存在するのかもしれませんが、見たことはありません。

スポンサーリンク

ACアダプターの容量判別 → OK?

まずは、接続されているACアダプターの容量判別を行う回路を疑いました。
LenovoのACアダプターには、45Wや65W、90W、130W・・・など、数種類の容量のACアダプターが存在していますが、それぞれ内部に仕込まれた抵抗値が違います。
この抵抗値はACアダプターのコネクターのセンターピン-GND間の抵抗値をテスターで測定すればわかります。

が・・・、Lenovo Vantageで認識状態を確認すると、容量ごとに正しく認識されています。
手持ちの45W、65W、90W、130Wの4種類を試しましたが、すべて問題ありません。

AC容量判別状態

ただ、ACアダプターを抜くと、「ACアダプターがサポートされていません。」と表示されます・・・

Vantage Incorrect MSG

つまり、ACアダプターの容量判別の回路は正常だが、バッテリー駆動にした時の回路に何か問題があるようです。

システムボード調査

ここまでの調査で、不具合の原因はシステムボード上の部品が壊れているなど、ハード的な問題だと判断し、システムボードの回路図とにらめっこしながら調査を続けました。

しかし、ACアダプターを挿している時は不具合なく普通に動作し、バッテリー駆動した際も、メッセージが出る以外は特に不具合がないため、なかなか発見できません。

挙句の果て、充電回路系のMOSFETなどを取り外して状態確認している内に今度はX260が起動しなくなってしまいました(汗)
どうも、(記憶にはないが・・・)充電制御のIC(PU101)をショートさせてしまったようで、調査を続行するには、先にこのICを交換しないといけません。
しかし、ちょうど運良く?、ヤ〇オクに不動X260システムボードが800円で出品されていたので、即決で落札して、そこからICをもぎ取り、元に戻して調査再開。

ヤフオク 不動X260システムボード

ショートしたPU101は、こんなICです。

PU101交換

そして調査を始めて約2ヶ月後、ようやく不具合箇所を見つけました!

スポンサーリンク

不具合の犯人はダイオードだった!

不具合箇所にたどり着くまでに、相当な時間と労力を費やしましたが、その内容はさておき、不具合の原因は充電制御のIC(PU101)に繋がっているダイオードのオープン故障でした。
このダイオードは、バッテリー駆動時に12VをPU101に送電する系統(VINT20)に配置されているもので、回路図上では「PD102」になります。

充電制御回路 不具合箇所

ここには、AC駆動時用とバッテリー駆動時用、ドック接続時用を含めて3系統が並列に配置されており、AC駆動時はDCIN_PWR20_Fから20V、バッテリー駆動時はVINT20から12Vがかかるようですが、PD102のオープン故障によりバッテリー駆動時に12VがPU101に到達せず、結果、このような現象となったようです

ダイオード実装位置

ということで、このダイオードも不動X260システムボードからもぎ取って交換!

PD102交換

ちなみにPD102の大きさはこんな感じです。

PD102の大きさ

テスターで問題ないことを確認した後、早速システムボードを組み付けて、バッテリーを接続。
AC駆動でBIOSまで立ち上げた状態でACアダプターを抜き、天板のThinkPadロゴ部の赤LEDを確認すると・・・点滅してません!

さらに強制電源OFFでLEDを確認すると・・・、消灯しています!!

無事、修理は成功したようです!

ヤッター!!!

まとめ

ジャンクX260は、せっかくi7 を搭載したマシンなので、色々といじりまくって楽しむ予定でしたが、思わぬトラブルに見舞われてしまいました。
素人の私に修理できるのか?不安しかない状態で、修理できるかどうかわからないマシンにお金を掛けるのは気が乗らず、解決できるまではすべてお預けとしていました。

一応、この問題は解決できましたが、また何か問題が出てきそうで不安です・・・
もうしばらく様子を見たうえで、次どうするか?考えたいと思います。

とにかく今回は色々ありすぎて記録からは割愛していますが、ThinkPadの充電制御回路など、役立つ知見を得ることができたので(正確に理解できているかは別として・・・)、今後おおいに活用していきたいと思います(活用するような場面に出くわさない方が良いが・・・)。

以上、備忘録でした。

↓ ジャンクX260の続きはこちら ↓
X260でDetection error on SSD(M.2)

KIOXIA SATA SSD 240GBをX260に取り付け!

X260 のSSDをPCIe Gen3 NVMeに換装!

↓ こちらもレアな不具合修理記録です (X1 Carbon 6th)↓
シャットダウンしても電源ランプが消えない!?ThinkPad修理記録
   


タイトルとURLをコピーしました